POJ 1157 LITTLE SHOP OF FLOWERS

题目描述

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.

POJ1157

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

Input

  • The first line contains two numbers: F, V.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.

  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.

  • F <= V <= 100 where V is the number of vases.
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

题目链接

http://poj.org/problem?id=1157

解题思路

题目很长,简单的意思就是在一个F行V列的矩阵中找出在不同行不同列中的F个数字的最大和,并且还要满足条件,后一行的数所在的列必须大于该行的数所在的列。

一道经典的DP,使用的动态转移方程为:dp[i][j] = max(dp[i][j - 1], dp[i - 1][j - 1] + a[i][j])

前提条件必须要初始化dp[i][i]的值,这几个值不能在方程中初始化,如果在方程中初始化,就不能满足后一行的列数大于前一行的列数这个条件了。

AC代码

220K/16MS/C++

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

int a[105][105], dp[105][105];
int main()
{
int F, V;
memset(dp, 0, sizeof(dp));
scanf("%d%d", &F, &V);
for (int i = 1; i <= F; i++)
{
for (int j = 1; j <= V; j++)
{
scanf("%d", &a[i][j]);
}
dp[i][i] = dp[i - 1][i - 1] + a[i][i];
}
for (int i = 1; i <= F; i++)
{
for (int j = i + 1; j <= V; j++)
{
dp[i][j] = max(dp[i][j - 1], dp[i - 1][j - 1] + a[i][j]);
}
}
printf("%d\n", dp[F][V]);
return 0;
}