POJ 1088 滑雪

题目描述

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

1 2 3 4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-…-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

题目链接

http://poj.org/problem?id=1088

解题思路

这道题一看就是DFS的题目,但是直接朴素的搜索会TLE。所以,我们就需要用到记忆化搜索了,一个简单的DP。dp[x][y]记录的是从点(x, y)出发最长的长度。每次搜索到相应的点的时候,如果改点存储的最大长度大于0的话,就直接返回这个点的最大长度,跳过这个点的搜索,这样就大大加快了时间。

这里所用到的动态转移方程为:dp[x][y] = max(dfs(x - 1, y), dfs(x + 1, y), dfs(x, y - 1), dfs(x, y + 1)) + 1

这里+1的原因是将自己这个点本身也算进去。

AC代码

220K/16MS/C++

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
#include <cstdio>
#include <iostream>
using namespace std;

int a[105][105], dp[105][105];
int m, n;
int dfs(int x, int y)
{
int maxn = 0;
if (dp[x][y] > 0) return dp[x][y];
if (y - 1 >= 0)
{
if (a[x][y] > a[x][y - 1])
{
maxn = max(maxn, dfs(x, y - 1));
}
}
if (y + 1 < m)
{
if (a[x][y] > a[x][y + 1])
{
maxn = max(maxn, dfs(x, y + 1));
}
}
if (x - 1 >= 0)
{
if (a[x][y] > a[x - 1][y])
{
maxn = max(maxn, dfs(x - 1, y));
}
}
if (x + 1 < n)
{
if (a[x][y] > a[x + 1][y])
{
maxn = max(maxn, dfs(x + 1, y));
}
}
return maxn + 1;
}

int main()
{
memset(dp, 0, sizeof(dp));
scanf("%d%d", &n, &m);
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m; j++)
{
scanf("%d", &a[i][j]);
}
}
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m; j++)
{
dp[i][j] = dfs(i, j);
}
}
int ans = 0;
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m; j++)
{
ans = max(ans, dp[i][j]);
}
}
printf("%d\n", ans);
return 0;
}